Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.
On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.
Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.
When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.
If there is no valid location for a new announcement, it is not put on the billboard (that’s why some programming contests have no participants from this university).
Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.
Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.
When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.
If there is no valid location for a new announcement, it is not put on the billboard (that’s why some programming contests have no participants from this university).
Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
Input
There are multiple cases (no more than 40 cases).
The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) – the dimensions of the billboard and the number of announcements.
Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) – the width of i-th announcement.
The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) – the dimensions of the billboard and the number of announcements.
Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) – the width of i-th announcement.
Output
For each announcement (in the order they are given in the input file) output one number – the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can’t be put on the billboard, output “-1” for this announcement.
Sample Input
3 5 5 2 4 3 3 3
Sample Output
1 2 1 3 -1
Title: A announcement plate of H*W should be announced on it.
- Input is a value of 1*wi, these are the size of the announcement
- The conditions to meet next are: 1. Try to go up as possible, try to leave as far as possible. 2. Find the number of rows where the n advertisement is located. 3. If there is no appropriate position, the output is output -1.
Line segment tree range the most valuable query and single -point update, code:
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn = 200000 + 5;
int s[maxn << 2];
int h,w,n;
void build(int d,int l,int r)
{
if(l == r)
{
s[d] = w;
return ;
}
int m = l + (r - l) / 2;
build(d<<1,l,m);
build(d<<1|1 ,m + 1,r);
s[d] = max(s[d<<1],s[d<<1|1]);
}
int query(int d,int x,int l,int r)
{
if(l == r)
{
s[d] -= x;
return l;
}
int m = l + (r - l) / 2;
int loc = s[d << 1] >= x ? query(d << 1,x,l,m) : query(d << 1 | 1,x,m + 1,r);
s[d] = max(s[d << 1],s[d << 1 | 1]);
return loc;
}
int main()
{
int x;
while(scanf("%d %d %d",&h,&w,&n)!=EOF)
{
h = h > n ? n : h;
build(1,1,h);
while(n--)
{
scanf("%d",&x);
if(s[1] < x) printf("%d\n",-1);
else printf("%d\n",query(1,x,1,h));
}
}
return 0;
}