Pagling label implementation

2023-03-16  

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X’: a block of wall, which the doggie cannot enter;
‘S’: the start point of the doggie;
‘D’: the Door; or
‘.’: an empty block.

The input is terminated with three 0’s. This test case is not to be processed.
Output
For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.
Sample Input
4 4 5
S.X.
…X.
…XD

3 4 5
S.X.
…X.
…D
0 0 0
Sample Output
NO
YES
s to D to walk out of the maze X in the step of D;
3 3 3:
在这里插入图片描述
We can use the formula T- [ABS (EX-SX)+ABS (EY-SY)] to calculate whether the Extra is even to determine whether the current point can just reach the end at so many steps. EXTRA means that the current point arrives The remaining time of the end.

ans=t-time-abs(dx-x)-abs(dy-y); 
if(ans<0||ans&1) return;
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
char map[9][9];
int n,m,t,x,dx,y,dy,ok;
int a[4][2]={
    {
    0,1},{
    0,-1},{
    1,0},{
    -1,0}};
void dfs(int x,int y,int time)
{
    
	int i,ans;
	if(x==dx&&y==dy&&time==t) ok=1;
	if(ok) return;
	if(x<1||y<1||x>n||y>m) return;  // Search the boundary.
	ans=t-time-abs(dx-x)-abs(dy-y); // Strange branches, it feels good.
	if(ans<0||ans&1) return;
	for(i=0;i<4;i++)
	{
    
		if(map[x+a[i][0]][y+a[i][1]]!='X') 
		{
    
			map[x+a[i][0]][y+a[i][1]]='X';
			dfs(x+a[i][0],y+a[i][1],time+1);
			map[x+a[i][0]][y+a[i][1]]='.';
		}
	}
}
int main()
{
    
	int i,j,k;
	while(scanf("%d%d%d",&n,&m,&t)!=EOF)
	{
    
		getchar();  // Note that this getchar () is not omitted, otherwise the output will always be NO. After looking for more than an hour, it is helpless.
		if(n==0&&m==0&&t==0)
		    break;
		for(i=1,k=0;i<=n;i++)
		{
    
			for(j=1;j<=m;j++)
			{
    
				scanf("%c",&map[i][j]);
				if(map[i][j]=='S') 
				{
    
				    x=i;
					y=j; 
				}
			    if(map[i][j]=='D')
				{
    
					dx=i;
					dy=j;
				}
				if(map[i][j]=='X')
				    k++;	
			}
			getchar();
		}
		if(n*m-k<t)  // The longest search time.
		   printf("NO\n");
		else
		{
    
		ok=0;
		map[x][y]='X';  // The mark has been visited.
		dfs(x,y,0);
		if(ok==1)
		    printf("YES\n");
		else    
		    printf("NO\n");
		  }
	}
	return 0;
}

source

Related Posts

Unity3D —— Model Click events

Openssl generate certificate G

X-axis length, that is, gray level axis_params = [] axis_params.append (0) axis_params.append (x_size) #plt.figure () if name! = None: PLT.TITLE (name) PLT.BAR (Tuple (Keys), Tuple (Values))#Draw a histogram #PLT.SHOW () #Map the ash array as a histogram dictionary, nums represents the magnitude of the grayness DEF ArrayTohist (Grayarray, Nums): if (len (grayarray.shape)! = 2): Print (“length error”) Return None w, h = Grayarray.shape Hist = {} For K in Range (NUMS): Hist [k] = 0 for I in Range (W): for j in range (h): if (hest.get (grayarray [i] [j]): is none): history [grayarray [i] [j]] = 0 Hist [grayarray [i] [j]] += 1 #normalize n = w*h for key in history.keys (): Hist [key] = float (history [key])/n Return Hist #Accut the cumulative histogram calculating new balanced pictures, nums is grayscale, 256 DEF Equalization (Grayarray, H_S, Nums): #Calculation accumulated histogram TMP = 0.0 h_acc = h_s.copy () for I in Range (256): TMP += H_S [i] h_acc [i] = tmp if (len (grayarray.shape)! = 2): Print (“length error”) Return None w, h = Grayarray.shape des = np.zeros ((w, h), dtype = np.uint8) for I in Range (W): for j in range (h): des [i] [j] = int ((nums – 1)* h_acc [grayarray [i] [j]] +0.5) Return des DEF HISTMATCH (Grayarray, H_D): #Calculation accumulated histogram TMP = 0.0 h_acc = h_d.copy () for I in Range (256): TMP += H_D [i] h_acc [i] = tmp h1 = Arraytohist (Grayarray, 256) TMP = 0.0 h1_acc = h1.copy () for I in Range (256): TMP += H1 [i] h1_acc [i] = tmp #Calculation mapping M = np.zeros (256) for I in Range (256): IDX = 0 minv = 1 for j in h_acc: if (np.fabs (h_acc [j] -h1_acc [i])

JDBC use The use of

Pagling label implementation

Random Posts

FLEX layout dictionary

DWR3 Implementation Message Precise Push Detailed Step

jumpserver docker-compose deployment file yunson

linux configuration ffmpeg

vmware cloning CentOS7 virtual machine