Redhat and Ubuntu Install FTPJ2EE

2023-03-15  

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13453    Accepted Submission(s): 8331




Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 


Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ – a black tile 

‘#’ – a red tile 

‘@’ – a man on a black tile(appears exactly once in a data set) 


Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 


Sample Input
  
   
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#[email protected]#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### [email protected] ###.### ..#.#.. ..#.#.. 0 0


Sample Output
  
   
45 59 6 13
Classic search questions, in -depth priority search, the description is as follows:
void dfs()
{
for (all adjacent nodes)
  {
if (nodes are not traversed)
      {
Standard this node;
dfs (this node);
      }
  }
}
This question code is as follows:

#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
using namespace std;

int w,c;
int p,q;
char arr[21][21];
int v[21][21];
int dir[4][2]={
      {
      1,0},{-1,0},{
      0,1},{
      0,-1}};
int count=0;

void DFS(int x,int y)
{
      
    for(int i=0;i<=3;i++)
    {
      
        int xx=x+dir[i][0];
        int yy=y+dir[i][1];
        if(xx>=0&&xx<c&&yy>=0&&yy<w&&arr[xx][yy]=='.'&&v[xx][yy]==0)
        {
      
            v[xx][yy]=1;
            count++;
            DFS(xx,yy);
        }
    }
}
int main()
{
      
    while(cin>>w>>c,w||c)
    {
      
        for(int i=0;i<c;i++)
           for(int j=0;j<w;j++)
           {
      
                   cin>>arr[i][j];
                   if(arr[i][j]=='@')
                   {
      
                       p=i;
                    q=j;
                }
                v[i][j]=0;
           }
        v[p][q]=1;
        count = 1;
        DFS(p,q);
        cout<<count<<endl;
    }
    return 0;
}

source

Related Posts

NIPS 2018 thesis interpret

OpenPose Installation Configuration Fool Version Tutorial

C ++ BFS Seeking the shortest path

C# Partial Class usage

Redhat and Ubuntu Install FTPJ2EE

Random Posts

Master this posture, girlfriend no longer talks about

Use Ado+Access for database operation

POJ 2762 (Weak Unicom: Qiang Liantong+Shining point+topology sorting) Weiguang

Python small details solution (continuously updated)

mysql data type